Stackurity Start free trial

CVEs / CVE-2019-11580

CVE-2019-11580: Atlassian Crowd and Crowd Data Center Remote Code Execution Vulnerability

Are you affected? Check your servers with Stackurity: it lists the software on each server and the vulnerabilities to fix first.

Check your servers with Stackurity Already using Stackurity? Search for CVE-2019-11580

Summary

Atlassian Crowd and Crowd Data Center contain a remote code execution vulnerability resulting from a pdkinstall development plugin being incorrectly enabled in release builds.

CISA, Known Exploited Vulnerabilities catalog

Description

Atlassian Crowd and Crowd Data Center had the pdkinstall development plugin incorrectly enabled in release builds. Attackers who can send unauthenticated or authenticated requests to a Crowd or Crowd Data Center instance can exploit this vulnerability to install arbitrary plugins, which permits remote code execution on systems running a vulnerable version of Crowd or Crowd Data Center. All versions of Crowd from version 2.1.0 before 3.0.5 (the fixed version for 3.0.x), from version 3.1.0 before 3.1.6 (the fixed version for 3.1.x), from version 3.2.0 before 3.2.8 (the fixed version for 3.2.x), from version 3.3.0 before 3.3.5 (the fixed version for 3.3.x), and from version 3.4.0 before 3.4.4 (the fixed version for 3.4.x) are affected by this vulnerability.

The CVE record, via NVD · published 3 Jun 2019 · NVD status: Analyzed

Affected and fixed versions

As stated by the CVE record (from the CNA)
ProductAffectedFixed in
Atlassian Crowdfrom 2.1.0, before unspecifiedunspecified
Atlassian Crowdfrom unspecified, before 3.0.53.0.5
Atlassian Crowdfrom 3.1.0, before unspecifiedunspecified
Atlassian Crowdfrom unspecified, before 3.1.63.1.6
Atlassian Crowdfrom 3.2.0, before unspecifiedunspecified
Atlassian Crowdfrom unspecified, before 3.2.83.2.8
Atlassian Crowdfrom 3.3.0, before unspecifiedunspecified
Atlassian Crowdfrom unspecified, before 3.3.53.3.5
Atlassian Crowdfrom 3.4.0, before unspecifiedunspecified
Atlassian Crowdfrom unspecified, before 3.4.43.4.4

Exploitation

In CISA KEV since3 Nov 2021
Due date for US federal agencies3 May 2022
Used in ransomware campaignsKnown
Required actionApply updates per vendor instructions.

Severity

CVSS 3.19.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Scored by NVD

References

Sources

Exploitation status from the CISA Known Exploited Vulnerabilities catalog. EPSS scores from FIRST. Descriptions, severity and references from the National Vulnerability Database. Open-source package versions from OSV (CC-BY 4.0). Text is shown as each source states it; Stackurity does not edit it. Check the vendor's advisory before acting.

This product uses data from the NVD API but is not endorsed or certified by the NVD.