Stackurity Start free trial

CVEs / CVE-2019-3396

CVE-2019-3396: Atlassian Confluence Server and Data Center Server-Side Template Injection Vulnerability

Are you affected? Check your servers with Stackurity: it lists the software on each server and the vulnerabilities to fix first.

Check your servers with Stackurity Already using Stackurity? Search for CVE-2019-3396

Summary

Atlassian Confluence Server and Data Center contain a server-side template injection vulnerability that may allow an attacker to achieve path traversal and remote code execution.

CISA, Known Exploited Vulnerabilities catalog

Description

The Widget Connector macro in Atlassian Confluence Server before version 6.6.12 (the fixed version for 6.6.x), from version 6.7.0 before 6.12.3 (the fixed version for 6.12.x), from version 6.13.0 before 6.13.3 (the fixed version for 6.13.x), and from version 6.14.0 before 6.14.2 (the fixed version for 6.14.x), allows remote attackers to achieve path traversal and remote code execution on a Confluence Server or Data Center instance via server-side template injection.

The CVE record, via NVD · published 25 Mar 2019 · NVD status: Analyzed

Affected and fixed versions

As stated by the CVE record (from the CNA)
ProductAffectedFixed in
Atlassian Confluence Serverfrom unspecified, before 6.6.126.6.12
Atlassian Confluence Serverfrom 6.7.0, before unspecifiedunspecified
Atlassian Confluence Serverfrom unspecified, before 6.12.36.12.3
Atlassian Confluence Serverfrom next of 6.13.0, before unspecifiedunspecified
Atlassian Confluence Serverfrom unspecified, before 6.13.36.13.3
Atlassian Confluence Serverfrom next of 6.14.0, before unspecifiedunspecified
Atlassian Confluence Serverfrom unspecified, before 6.14.26.14.2

Exploitation

In CISA KEV since3 Nov 2021
Due date for US federal agencies3 May 2022
Used in ransomware campaignsKnown
Required actionApply updates per vendor instructions.

Severity

CVSS 3.19.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Scored by NVD
WeaknessCWE-22

References

Sources

Exploitation status from the CISA Known Exploited Vulnerabilities catalog. EPSS scores from FIRST. Descriptions, severity and references from the National Vulnerability Database. Open-source package versions from OSV (CC-BY 4.0). Text is shown as each source states it; Stackurity does not edit it. Check the vendor's advisory before acting.

This product uses data from the NVD API but is not endorsed or certified by the NVD.