Stackurity Start free trial

CVEs / CVE-2019-3398

CVE-2019-3398: Atlassian Confluence Server and Data Center Path Traversal Vulnerability

Are you affected? Check your servers with Stackurity: it lists the software on each server and the vulnerabilities to fix first.

Check your servers with Stackurity Already using Stackurity? Search for CVE-2019-3398

Summary

Atlassian Confluence Server and Data Center contain a path traversal vulnerability in the downloadallattachments resource that may allow a privileged, remote attacker to write files. Exploitation can lead to remote code execution.

CISA, Known Exploited Vulnerabilities catalog

Description

Confluence Server and Data Center had a path traversal vulnerability in the downloadallattachments resource. A remote attacker who has permission to add attachments to pages and / or blogs or to create a new space or a personal space or who has 'Admin' permissions for a space can exploit this path traversal vulnerability to write files to arbitrary locations which can lead to remote code execution on systems that run a vulnerable version of Confluence Server or Data Center. All versions of Confluence Server from 2.0.0 before 6.6.13 (the fixed version for 6.6.x), from 6.7.0 before 6.12.4 (the fixed version for 6.12.x), from 6.13.0 before 6.13.4 (the fixed version for 6.13.x), from 6.14.0 before 6.14.3 (the fixed version for 6.14.x), and from 6.15.0 before 6.15.2 are affected by this vulnerability.

The CVE record, via NVD · published 18 Apr 2019 · NVD status: Analyzed

Affected and fixed versions

As stated by the CVE record (from the CNA)
ProductAffectedFixed in
Atlassian Confluencefrom 2.0.0, before unspecifiedunspecified
Atlassian Confluencefrom unspecified, before 6.6.136.6.13
Atlassian Confluencefrom 6.7.0, before unspecifiedunspecified
Atlassian Confluencefrom unspecified, before 6.12.46.12.4
Atlassian Confluencefrom 6.13.0, before unspecifiedunspecified
Atlassian Confluencefrom unspecified, before 6.13.46.13.4
Atlassian Confluencefrom 6.14.0, before unspecifiedunspecified
Atlassian Confluencefrom unspecified, before 6.14.36.14.3
Atlassian Confluencefrom 6.15.0, before unspecifiedunspecified
Atlassian Confluencefrom unspecified, before 6.15.26.15.2

Exploitation

In CISA KEV since3 Nov 2021
Due date for US federal agencies3 May 2022
Used in ransomware campaignsUnknown
Required actionApply updates per vendor instructions.

Severity

CVSS 3.18.8 high
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Scored by NVD
WeaknessCWE-22

References

Sources

Exploitation status from the CISA Known Exploited Vulnerabilities catalog. EPSS scores from FIRST. Descriptions, severity and references from the National Vulnerability Database. Open-source package versions from OSV (CC-BY 4.0). Text is shown as each source states it; Stackurity does not edit it. Check the vendor's advisory before acting.

This product uses data from the NVD API but is not endorsed or certified by the NVD.