Stackurity Start free trial

CVEs / CVE-2020-11023

CVE-2020-11023: JQuery Cross-Site Scripting (XSS) Vulnerability

Are you affected? Check your servers with Stackurity: it lists the software on each server and the vulnerabilities to fix first.

Check your servers with Stackurity Already using Stackurity? Search for CVE-2020-11023

Summary

JQuery contains a persistent cross-site scripting (XSS) vulnerability. When passing maliciously formed, untrusted input enclosed in HTML tags, JQuery's DOM manipulators can execute untrusted code in the context of the user's browser.

CISA, Known Exploited Vulnerabilities catalog

Description

In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing <option> elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

The CVE record, via NVD · published 29 Apr 2020 · NVD status: Analyzed

Affected and fixed versions

As stated by the CVE record (from the CNA)
ProductAffectedFixed in
jquery jQuery>= 1.0.3, < 3.5.0—
As stated by OSV
ProductAffectedFixed in
jquery (npm)from 1.0.3, before 3.5.03.5.0
jquery-rails (RubyGems)before 4.4.04.4.0
jQuery (NuGet)from 1.0.3, before 3.5.03.5.0
org.webjars.npm:jquery (Maven)from 1.0.3, before 3.5.03.5.0
components/jquery (Packagist)from 1.0.3, before 3.5.03.5.0

Package versions from GHSA-jpcq-cgw6-v4j6.

Exploitation

In CISA KEV since23 Jan 2025
Due date for US federal agencies13 Feb 2025
Used in ransomware campaignsUnknown
Required actionApply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.

Severity

CVSS 3.16.1 medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Scored by NVD
WeaknessCWE-79

References

Sources

Exploitation status from the CISA Known Exploited Vulnerabilities catalog. EPSS scores from FIRST. Descriptions, severity and references from the National Vulnerability Database. Open-source package versions from OSV (CC-BY 4.0). Text is shown as each source states it; Stackurity does not edit it. Check the vendor's advisory before acting.

This product uses data from the NVD API but is not endorsed or certified by the NVD.