Stackurity Start free trial

CVEs / CVE-2020-17519

CVE-2020-17519: Apache Flink Improper Access Control Vulnerability

Are you affected? Check your servers with Stackurity: it lists the software on each server and the vulnerabilities to fix first.

Check your servers with Stackurity Already using Stackurity? Search for CVE-2020-17519

Summary

Apache Flink contains an improper access control vulnerability that allows an attacker to read any file on the local filesystem of the JobManager through its REST interface.

CISA, Known Exploited Vulnerabilities catalog

Description

A change introduced in Apache Flink 1.11.0 (and released in 1.11.1 and 1.11.2 as well) allows attackers to read any file on the local filesystem of the JobManager through the REST interface of the JobManager process. Access is restricted to files accessible by the JobManager process. All users should upgrade to Flink 1.11.3 or 1.12.0 if their Flink instance(s) are exposed. The issue was fixed in commit b561010b0ee741543c3953306037f00d7a9f0801 from apache/flink:master.

The CVE record, via NVD · published 5 Jan 2021 · NVD status: Analyzed

Affected and fixed versions

As stated by the CVE record (from the CNA)
ProductAffectedFixed in
Apache Software Foundation Apache FlinkApache Flink 1.11.0 to 1.11.2—
apache flinkfrom 1.11.0, up to and including 1.11.2—
As stated by OSV
ProductAffectedFixed in
org.apache.flink:flink-runtime_2.11 (Maven)from 1.11.0, before 1.11.31.11.3
org.apache.flink:flink-runtime_2.12 (Maven)from 1.11.0, before 1.11.31.11.3

Package versions from GHSA-395w-qhqr-9fr6.

Exploitation

In CISA KEV since23 May 2024
Due date for US federal agencies13 Jun 2024
Used in ransomware campaignsUnknown
Required actionApply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.

Severity

CVSS 3.17.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Scored by NVD
WeaknessCWE-552

References

Sources

Exploitation status from the CISA Known Exploited Vulnerabilities catalog. EPSS scores from FIRST. Descriptions, severity and references from the National Vulnerability Database. Open-source package versions from OSV (CC-BY 4.0). Text is shown as each source states it; Stackurity does not edit it. Check the vendor's advisory before acting.

This product uses data from the NVD API but is not endorsed or certified by the NVD.