Stackurity Start free trial

CVEs / CVE-2021-21311

CVE-2021-21311: Adminer Server-Side Request Forgery Vulnerability

Are you affected? Check your servers with Stackurity: it lists the software on each server and the vulnerabilities to fix first.

Check your servers with Stackurity Already using Stackurity? Search for CVE-2021-21311

Summary

Adminer contains a server-side request forgery vulnerability that, when exploited, allows a remote attacker to obtain potentially sensitive information.

CISA, Known Exploited Vulnerabilities catalog

Description

Adminer is an open-source database management in a single PHP file. In adminer from version 4.0.0 and before 4.7.9 there is a server-side request forgery vulnerability. Users of Adminer versions bundling all drivers (e.g. `adminer.php`) are affected. This is fixed in version 4.7.9.

The CVE record, via NVD · published 11 Feb 2021 · NVD status: Analyzed

Affected and fixed versions

As stated by the CVE record (from the CNA)
ProductAffectedFixed in
vrana adminer>= 4.0.0, < 4.7.9—
As stated by OSV
ProductAffectedFixed in
vrana/adminer (Packagist)before 4.7.94.7.9

Package versions from GHSA-x5r2-hj5c-8jx6.

Exploitation

In CISA KEV since29 Sep 2025
Due date for US federal agencies20 Oct 2025
Used in ransomware campaignsUnknown
Required actionApply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.

Severity

CVSS 3.17.2 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
Scored by NVD
WeaknessCWE-918

References

Sources

Exploitation status from the CISA Known Exploited Vulnerabilities catalog. EPSS scores from FIRST. Descriptions, severity and references from the National Vulnerability Database. Open-source package versions from OSV (CC-BY 4.0). Text is shown as each source states it; Stackurity does not edit it. Check the vendor's advisory before acting.

This product uses data from the NVD API but is not endorsed or certified by the NVD.