Stackurity Start free trial

CVEs / CVE-2023-32315

CVE-2023-32315: Ignite Realtime Openfire Path Traversal Vulnerability

Are you affected? Check your servers with Stackurity: it lists the software on each server and the vulnerabilities to fix first.

Check your servers with Stackurity Already using Stackurity? Search for CVE-2023-32315

Summary

Ignite Realtime Openfire contains a path traversal vulnerability that allows an unauthenticated attacker to access restricted pages in the Openfire Admin Console reserved for administrative users.

CISA, Known Exploited Vulnerabilities catalog

Description

Openfire is an XMPP server licensed under the Open Source Apache License. Openfire's administrative console, a web-based application, was found to be vulnerable to a path traversal attack via the setup environment. This permitted an unauthenticated user to use the unauthenticated Openfire Setup Environment in an already configured Openfire environment to access restricted pages in the Openfire Admin Console reserved for administrative users. This vulnerability affects all versions of Openfire that have been released since April 2015, starting with version 3.10.0. The problem has been patched in Openfire release 4.7.5 and 4.6.8, and further improvements will be included in the yet-to-be released first version on the 4.8 branch (which is expected to be version 4.8.0). Users are advised to upgrade. If an Openfire upgrade isn’t available for a specific release, or isn’t quickly actionable, users may see the linked github advisory (GHSA-gw42-f939-fhvm) for mitigation advice.

The CVE record, via NVD · published 26 May 2023 · NVD status: Analyzed

Affected and fixed versions

As stated by the CVE record (from the CNA)
ProductAffectedFixed in
igniterealtime Openfire>= 3.10.0, < 4.6.8—
igniterealtime Openfire>= 4.7.0, < 4.7.5—
As stated by OSV
ProductAffectedFixed in
org.igniterealtime.openfire:xmppserver (Maven)from 3.10.0, before 4.6.84.6.8
org.igniterealtime.openfire:xmppserver (Maven)from 4.7.0, before 4.7.54.7.5

Package versions from GHSA-gw42-f939-fhvm.

Exploitation

In CISA KEV since24 Aug 2023
Due date for US federal agencies14 Sep 2023
Used in ransomware campaignsUnknown
Required actionApply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.

Severity

CVSS 3.17.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Scored by NVD
WeaknessCWE-22

References

Sources

Exploitation status from the CISA Known Exploited Vulnerabilities catalog. EPSS scores from FIRST. Descriptions, severity and references from the National Vulnerability Database. Open-source package versions from OSV (CC-BY 4.0). Text is shown as each source states it; Stackurity does not edit it. Check the vendor's advisory before acting.

This product uses data from the NVD API but is not endorsed or certified by the NVD.