Stackurity Start free trial

CVEs / CVE-2023-33246

CVE-2023-33246: Apache RocketMQ Command Execution Vulnerability

Are you affected? Check your servers with Stackurity: it lists the software on each server and the vulnerabilities to fix first.

Check your servers with Stackurity Already using Stackurity? Search for CVE-2023-33246

Summary

Several components of Apache RocketMQ, including NameServer, Broker, and Controller, are exposed to the extranet and lack permission verification. An attacker can exploit this vulnerability by using the update configuration function to execute commands as the system users that RocketMQ is running as or achieve the same effect by forging the RocketMQ protocol content.

CISA, Known Exploited Vulnerabilities catalog

Description

For RocketMQ versions 5.1.0 and below, under certain conditions, there is a risk of remote command execution.  Several components of RocketMQ, including NameServer, Broker, and Controller, are leaked on the extranet and lack permission verification, an attacker can exploit this vulnerability by using the update configuration function to execute commands as the system users that RocketMQ is running as. Additionally, an attacker can achieve the same effect by forging the RocketMQ protocol content.  To prevent these attacks, users are recommended to upgrade to version 5.1.1 or above for using RocketMQ 5.x or 4.9.6 or above for using RocketMQ 4.x .

The CVE record, via NVD · published 24 May 2023 · NVD status: Analyzed

Affected and fixed versions

As stated by the CVE record (from the CNA)
ProductAffectedFixed in
Apache Software Foundation Apache RocketMQup to and including 5.1.0—
As stated by OSV
ProductAffectedFixed in
org.apache.rocketmq:rocketmq-broker (Maven)from 5.0.0, before 5.1.15.1.1
org.apache.rocketmq:rocketmq-namesrv (Maven)from 4.0.0, before 4.9.64.9.6
org.apache.rocketmq:rocketmq-controller (Maven)from 5.0.0, before 5.1.15.1.1
org.apache.rocketmq:rocketmq-namesrv (Maven)from 5.0.0, before 5.1.15.1.1

Package versions from GHSA-x3cq-8f32-5f63.

Exploitation

In CISA KEV since6 Sep 2023
Due date for US federal agencies27 Sep 2023
Used in ransomware campaignsUnknown
Required actionApply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.

Severity

CVSS 3.19.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Scored by NVD
WeaknessCWE-94

References

Sources

Exploitation status from the CISA Known Exploited Vulnerabilities catalog. EPSS scores from FIRST. Descriptions, severity and references from the National Vulnerability Database. Open-source package versions from OSV (CC-BY 4.0). Text is shown as each source states it; Stackurity does not edit it. Check the vendor's advisory before acting.

This product uses data from the NVD API but is not endorsed or certified by the NVD.