CVEs / CVE-2023-43770
CVE-2023-43770: Roundcube Webmail Persistent Cross-Site Scripting (XSS) Vulnerability
- Known exploited in the CISA KEV catalog since 12 Feb 2024
- medium 6.1 CVSS 3.1 (NVD)
- EPSS 63.6% chance of exploitation in the next 30 days, higher than 99% of CVEs (30 Oct 2026)
- Last changed at its sources
Are you affected? Check your servers with Stackurity: it lists the software on each server and the vulnerabilities to fix first.
Check your servers with Stackurity Already using Stackurity? Search for CVE-2023-43770
Summary
Roundcube Webmail contains a persistent cross-site scripting (XSS) vulnerability that can lead to information disclosure via malicious link references in plain/text messages.
Description
Roundcube before 1.4.14, 1.5.x before 1.5.4, and 1.6.x before 1.6.3 allows XSS via text/plain e-mail messages with crafted links because of program/lib/Roundcube/rcube_string_replacer.php behavior.
Affected and fixed versions
| Product | Affected | Fixed in |
|---|---|---|
| n/a n/a | n/a | — |
| roundcube webmail | before 1.4.14 | 1.4.14 |
| roundcube webmail | from 1.5.0, before 1.5.4 | 1.5.4 |
| roundcube webmail | from 1.6.0, before 1.6.3 | 1.6.3 |
| debian debian_linux | 10 | — |
Exploitation
| In CISA KEV since | 12 Feb 2024 |
|---|---|
| Due date for US federal agencies | 4 Mar 2024 |
| Used in ransomware campaigns | Unknown |
| Required action | Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable. |
Severity
| CVSS 3.1 | 6.1 mediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NScored by NVD |
|---|---|
| Weakness | CWE-79 |
References
- CVE-2023-43770 on NVD
- CVE-2023-43770 in the CISA KEV catalog
- https://roundcube.net/news/2023/09/15/security-update-1.6.3-released (cited by CISA)
- CVE-2023-43770 on OSV
- https://github.com/roundcube/roundcubemail/commit/e92ec206a886461245e1672d8530cc93c618a49b Patch
- https://lists.debian.org/debian-lts-announce/2023/09/msg00024.html Mailing List
- https://roundcube.net/news/2023/09/15/security-update-1.6.3-released Release Notes
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2023-43770 US Government Resource
Sources
Exploitation status from the CISA Known Exploited Vulnerabilities catalog. EPSS scores from FIRST. Descriptions, severity and references from the National Vulnerability Database. Open-source package versions from OSV (CC-BY 4.0). Text is shown as each source states it; Stackurity does not edit it. Check the vendor's advisory before acting.
This product uses data from the NVD API but is not endorsed or certified by the NVD.