Stackurity Start free trial

CVEs / CVE-2024-45195

CVE-2024-45195: Apache OFBiz Forced Browsing Vulnerability

Are you affected? Check your servers with Stackurity: it lists the software on each server and the vulnerabilities to fix first.

Check your servers with Stackurity Already using Stackurity? Search for CVE-2024-45195

Summary

Apache OFBiz contains a forced browsing vulnerability that allows a remote attacker to obtain unauthorized access.

CISA, Known Exploited Vulnerabilities catalog

Description

Direct Request ('Forced Browsing') vulnerability in Apache OFBiz. This issue affects Apache OFBiz: before 18.12.16. Users are recommended to upgrade to version 18.12.16, which fixes the issue.

The CVE record, via NVD · published 4 Sep 2024 · NVD status: Analyzed

Affected and fixed versions

As stated by the CVE record (from the CNA)
ProductAffectedFixed in
Apache Software Foundation Apache OFBizbefore 18.12.1618.12.16
apache ofbizbefore 18.12.1618.12.16

Exploitation

In CISA KEV since4 Feb 2025
Due date for US federal agencies25 Feb 2025
Used in ransomware campaignsUnknown
Required actionApply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.

Severity

CVSS 3.17.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Scored by NVD
WeaknessCWE-425

References

Sources

Exploitation status from the CISA Known Exploited Vulnerabilities catalog. EPSS scores from FIRST. Descriptions, severity and references from the National Vulnerability Database. Open-source package versions from OSV (CC-BY 4.0). Text is shown as each source states it; Stackurity does not edit it. Check the vendor's advisory before acting.

This product uses data from the NVD API but is not endorsed or certified by the NVD.