Stackurity Start free trial

CVEs / CVE-2024-51567

CVE-2024-51567: CyberPanel Incorrect Default Permissions Vulnerability

Are you affected? Check your servers with Stackurity: it lists the software on each server and the vulnerabilities to fix first.

Check your servers with Stackurity Already using Stackurity? Search for CVE-2024-51567

Summary

CyberPanel contains an incorrect default permissions vulnerability that allows a remote, unauthenticated attacker to execute commands as root.

CISA, Known Exploited Vulnerabilities catalog

Description

upgrademysqlstatus in databases/views.py in CyberPanel (aka Cyber Panel) before 5b08cd6 allows remote attackers to bypass authentication and execute arbitrary commands via /dataBases/upgrademysqlstatus by bypassing secMiddleware (which is only for a POST request) and using shell metacharacters in the statusfile property, as exploited in the wild in October 2024 by PSAUX. Versions through 2.3.6 and (unpatched) 2.3.7 are affected.

The CVE record, via NVD · published 29 Oct 2024 · NVD status: Analyzed

Affected and fixed versions

As stated by the CVE record (from the CNA)
ProductAffectedFixed in
n/a n/an/a—
cyberpanel cyberpanelup to and including 5b08cd6—

Exploitation

In CISA KEV since7 Nov 2024
Due date for US federal agencies28 Nov 2024
Used in ransomware campaignsKnown
Required actionApply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.

Severity

CVSS 3.19.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Scored by NVD
WeaknessCWE-306

References

Sources

Exploitation status from the CISA Known Exploited Vulnerabilities catalog. EPSS scores from FIRST. Descriptions, severity and references from the National Vulnerability Database. Open-source package versions from OSV (CC-BY 4.0). Text is shown as each source states it; Stackurity does not edit it. Check the vendor's advisory before acting.

This product uses data from the NVD API but is not endorsed or certified by the NVD.