CVEs / CVE-2024-52012
CVE-2024-52012: Apache Software Foundation Apache Solr vulnerability
- medium 5.4 CVSS 3.1 (from the CNA)
- EPSS 47.1% chance of exploitation in the next 30 days, higher than 98% of CVEs (3 Nov 2026)
- Last changed at its sources
Are you affected? Check your servers with Stackurity: it lists the software on each server and the vulnerabilities to fix first.
Check your servers with Stackurity Already using Stackurity? Search for CVE-2024-52012
Description
Relative Path Traversal vulnerability in Apache Solr. Solr instances running on Windows are vulnerable to arbitrary filepath write-access, due to a lack of input-sanitation in the "configset upload" API. Commonly known as a "zipslip", maliciously constructed ZIP files can use relative filepaths to write data to unanticipated parts of the filesystem. This issue affects Apache Solr: from 6.6 through 9.7.0. Users are recommended to upgrade to version 9.8.0, which fixes the issue. Users unable to upgrade may also safely prevent the issue by using Solr's "Rule-Based Authentication Plugin" to restrict access to the configset upload API, so that it can only be accessed by a trusted set of administrators/users.
Affected and fixed versions
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software Foundation Apache Solr | from 6.6, up to and including 9.7.0 | — |
| Product | Affected | Fixed in |
|---|---|---|
| org.apache.solr:solr-core (Maven) | from 6.6, before 9.8.0 | 9.8.0 |
Package versions from GHSA-4p5m-gvpf-f3x5.
Exploitation
Not in the CISA Known Exploited Vulnerabilities catalog as of 3 Nov 2026.
Severity
| CVSS 3.1 | 5.4 mediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:NScored by the CNA (134c704f-9b21-4f2e-91b3-4a467353bcc0) |
|---|---|
| Weakness | CWE-23 |
References
- CVE-2024-52012 on NVD
- CVE-2024-52012 on OSV
- https://lists.apache.org/thread/yp39pgbv4vf1746pf5yblz84lv30vfxd Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2025/01/26/2 Mailing List, Third Party Advisory
Sources
Exploitation status from the CISA Known Exploited Vulnerabilities catalog. EPSS scores from FIRST. Descriptions, severity and references from the National Vulnerability Database. Open-source package versions from OSV (CC-BY 4.0). Text is shown as each source states it; Stackurity does not edit it. Check the vendor's advisory before acting.
This product uses data from the NVD API but is not endorsed or certified by the NVD.