CVEs / CVE-2024-56145
CVE-2024-56145: Craft CMS Code Injection Vulnerability
- Known exploited in the CISA KEV catalog since 2 Jun 2025
- critical 9.8 CVSS 3.1 (NVD)
- EPSS 97.4% chance of exploitation in the next 30 days, higher than 99% of CVEs (30 Oct 2026)
- Last changed at its sources
Are you affected? Check your servers with Stackurity: it lists the software on each server and the vulnerabilities to fix first.
Check your servers with Stackurity Already using Stackurity? Search for CVE-2024-56145
Summary
Craft CMS contains a code injection vulnerability. Users with affected versions are vulnerable to remote code execution if their php.ini configuration has `register_argc_argv` enabled.
Description
Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. Users of affected versions are affected by this vulnerability if their php.ini configuration has `register_argc_argv` enabled. For these users an unspecified remote code execution vector is present. Users are advised to update to version 3.9.14, 4.13.2, or 5.5.2. Users unable to upgrade should disable `register_argc_argv` to mitigate the issue.
Affected and fixed versions
| Product | Affected | Fixed in |
|---|---|---|
| craftcms cms | >= 4.0.0-RC1, < 4.13.2 | — |
| craftcms cms | >= 5.0.0-RC1, < 5.5.2 | — |
| craftcms cms | >= 3.0.0, < 3.9.14 | — |
| Product | Affected | Fixed in |
|---|---|---|
| craftcms/cms (Packagist) | from 5.0.0-RC1, before 5.5.2 | 5.5.2 |
| craftcms/cms (Packagist) | from 4.0.0-RC1, before 4.13.2 | 4.13.2 |
| craftcms/cms (Packagist) | from 3.0.0, before 3.9.14 | 3.9.14 |
Package versions from GHSA-2p6p-9rc9-62j9.
Exploitation
| In CISA KEV since | 2 Jun 2025 |
|---|---|
| Due date for US federal agencies | 23 Jun 2025 |
| Used in ransomware campaigns | Unknown |
| Required action | Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable. |
Severity
| CVSS 3.1 | 9.8 criticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HScored by NVD |
|---|---|
| Weakness | CWE-94 |
References
- CVE-2024-56145 on NVD
- CVE-2024-56145 in the CISA KEV catalog
- https://github.com/craftcms/cms/security/advisories/GHSA-2p6p-9rc9-62j9 (cited by CISA)
- CVE-2024-56145 on OSV
- https://github.com/craftcms/cms/commit/82e893fb794d30563da296bca31379c0df0079b3 Patch
- https://github.com/craftcms/cms/security/advisories/GHSA-2p6p-9rc9-62j9 Vendor Advisory
- https://github.com/Chocapikk/CVE-2024-56145 Exploit
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2024-56145 US Government Resource
Sources
Exploitation status from the CISA Known Exploited Vulnerabilities catalog. EPSS scores from FIRST. Descriptions, severity and references from the National Vulnerability Database. Open-source package versions from OSV (CC-BY 4.0). Text is shown as each source states it; Stackurity does not edit it. Check the vendor's advisory before acting.
This product uses data from the NVD API but is not endorsed or certified by the NVD.