CVEs / CVE-2025-23209
CVE-2025-23209: Craft CMS Code Injection Vulnerability
- Known exploited in the CISA KEV catalog since 20 Feb 2025
- high 8.1 CVSS 3.1 (NVD)
- EPSS 21.6% chance of exploitation in the next 30 days, higher than 97% of CVEs (30 Oct 2026)
- Last changed at its sources
Are you affected? Check your servers with Stackurity: it lists the software on each server and the vulnerabilities to fix first.
Check your servers with Stackurity Already using Stackurity? Search for CVE-2025-23209
Summary
Craft CMS contains a code injection vulnerability caused by improper validation of the database backup path, ultimately enabling remote code execution.
Description
Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. This is an remote code execution (RCE) vulnerability that affects Craft 4 and 5 installs where your security key has already been compromised. Anyone running an unpatched version of Craft with a compromised security key is affected. This vulnerability has been patched in Craft 5.5.8 and 4.13.8. Users who cannot update to a patched version, should rotate their security keys and ensure their privacy to help migitgate the issue.
Affected and fixed versions
| Product | Affected | Fixed in |
|---|---|---|
| craftcms cms | >= 5.0.0-RC1, < 5.5.5 | — |
| craftcms cms | >= 4.0.0-RC1, < 4.13.8 | — |
| Product | Affected | Fixed in |
|---|---|---|
| craftcms/cms (Packagist) | from 5.0.0-RC1, before 5.5.8 | 5.5.8 |
| craftcms/cms (Packagist) | from 4.0.0-RC1, before 4.13.8 | 4.13.8 |
Package versions from GHSA-x684-96hh-833x.
Exploitation
| In CISA KEV since | 20 Feb 2025 |
|---|---|
| Due date for US federal agencies | 13 Mar 2025 |
| Used in ransomware campaigns | Unknown |
| Required action | Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable. |
Severity
| CVSS 3.1 | 8.1 highCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:HScored by NVD |
|---|---|
| Weakness | CWE-94 |
References
- CVE-2025-23209 on NVD
- CVE-2025-23209 in the CISA KEV catalog
- https://github.com/craftcms/cms/security/advisories/GHSA-x684-96hh-833x (cited by CISA)
- CVE-2025-23209 on OSV
- https://craftcms.com/knowledge-base/securing-craft#keep-your-secrets-secret Product
- https://github.com/craftcms/cms/commit/e59e22b30c9dd39e5e2c7fe02c147bcbd004e603 Patch
- https://github.com/craftcms/cms/security/advisories/GHSA-x684-96hh-833x Vendor Advisory
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-23209 US Government Resource
Sources
Exploitation status from the CISA Known Exploited Vulnerabilities catalog. EPSS scores from FIRST. Descriptions, severity and references from the National Vulnerability Database. Open-source package versions from OSV (CC-BY 4.0). Text is shown as each source states it; Stackurity does not edit it. Check the vendor's advisory before acting.
This product uses data from the NVD API but is not endorsed or certified by the NVD.