CVEs / CVE-2025-24367
CVE-2025-24367: Cacti cacti vulnerability
- high 8.8 CVSS 3.1 (NVD)
- EPSS 58.8% chance of exploitation in the next 30 days, higher than 99% of CVEs (3 Nov 2026)
- Last changed at its sources
Are you affected? Check your servers with Stackurity: it lists the software on each server and the vulnerabilities to fix first.
Check your servers with Stackurity Already using Stackurity? Search for CVE-2025-24367
Description
Cacti is an open source performance and fault management framework. An authenticated Cacti user can abuse graph creation and graph template functionality to create arbitrary PHP scripts in the web root of the application, leading to remote code execution on the server. This vulnerability is fixed in 1.2.29.
Affected and fixed versions
| Product | Affected | Fixed in |
|---|---|---|
| Cacti cacti | <= 1.2.28 | — |
Exploitation
Not in the CISA Known Exploited Vulnerabilities catalog as of 3 Nov 2026.
Severity
| CVSS 3.1 | 8.8 highCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HScored by NVD |
|---|---|
| Weakness | CWE-144 |
References
- CVE-2025-24367 on NVD
- CVE-2025-24367 on OSV
- https://github.com/Cacti/cacti/commit/c7e4ee798d263a3209ae6e7ba182c7b65284d8f0 Patch
- https://github.com/Cacti/cacti/security/advisories/GHSA-fxrq-fr7h-9rqq Exploit, Vendor Advisory
- https://lists.debian.org/debian-lts-announce/2025/02/msg00010.html
Sources
Exploitation status from the CISA Known Exploited Vulnerabilities catalog. EPSS scores from FIRST. Descriptions, severity and references from the National Vulnerability Database. Open-source package versions from OSV (CC-BY 4.0). Text is shown as each source states it; Stackurity does not edit it. Check the vendor's advisory before acting.
This product uses data from the NVD API but is not endorsed or certified by the NVD.