CVEs / CVE-2025-24813
CVE-2025-24813: Apache Tomcat Path Equivalence Vulnerability
- Known exploited in the CISA KEV catalog since 1 Apr 2025
- critical 9.8 CVSS 3.1 (NVD)
- EPSS 99.9% chance of exploitation in the next 30 days, higher than 99% of CVEs (30 Oct 2026)
- Last changed at its sources
Are you affected? Check your servers with Stackurity: it lists the software on each server and the vulnerabilities to fix first.
Check your servers with Stackurity Already using Stackurity? Search for CVE-2025-24813
Summary
Apache Tomcat contains a path equivalence vulnerability that allows a remote attacker to execute code, disclose information, or inject malicious content via a partial PUT request. This vulnerability can be chained with CVE‑2026‑34486.
Description
Path Equivalence: 'file.Name' (Internal Dot) leading to Remote Code Execution and/or Information disclosure and/or malicious content added to uploaded files via write enabled Default Servlet in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.2, from 10.1.0-M1 through 10.1.34, from 9.0.0.M1 through 9.0.98. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. If all of the following were true, a malicious user was able to view security sensitive files and/or inject content into those files: - writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - a target URL for security sensitive uploads that was a sub-directory of a target URL for public uploads - attacker knowledge of the names of security sensitive files being uploaded - the security sensitive files also being uploaded via partial PUT If all of the following were true, a malicious user was able to perform remote code execution: - writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - application was using Tomcat's file based session persistence with the default storage location - application included a library that may be leveraged in a deserialization attack Users are recommended to upgrade to version 11.0.3, 10.1.35 or 9.0.99, which fixes the issue.
Affected and fixed versions
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software Foundation Apache Tomcat | from 11.0.0-M1, up to and including 11.0.2 | — |
| Apache Software Foundation Apache Tomcat | from 10.1.0-M1, up to and including 10.1.34 | — |
| Apache Software Foundation Apache Tomcat | from 9.0.0.M1, up to and including 9.0.98 | — |
| Apache Software Foundation Apache Tomcat | from 8.5.0, up to and including 8.5.100 | — |
| Product | Affected | Fixed in |
|---|---|---|
| org.apache.tomcat:tomcat-catalina (Maven) | from 11.0.0-M1, before 11.0.3 | 11.0.3 |
| org.apache.tomcat:tomcat-catalina (Maven) | from 10.1.0-M1, before 10.1.35 | 10.1.35 |
| org.apache.tomcat:tomcat-catalina (Maven) | from 9.0.0.M1, before 9.0.99 | 9.0.99 |
| org.apache.tomcat.embed:tomcat-embed-core (Maven) | from 11.0.0-M1, before 11.0.3 | 11.0.3 |
| org.apache.tomcat.embed:tomcat-embed-core (Maven) | from 10.1.0-M1, before 10.1.35 | 10.1.35 |
| org.apache.tomcat.embed:tomcat-embed-core (Maven) | from 9.0.0.M1, before 9.0.99 | 9.0.99 |
| org.apache.tomcat:tomcat-catalina (Maven) | from 8.5.0, up to and including 8.5.100 | — |
| org.apache.tomcat.embed:tomcat-embed-core (Maven) | from 8.5.0, up to and including 8.5.100 | — |
Package versions from GHSA-83qj-6fr2-vhqg.
Exploitation
| In CISA KEV since | 1 Apr 2025 |
|---|---|
| Due date for US federal agencies | 22 Apr 2025 |
| Used in ransomware campaigns | Unknown |
| Required action | Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable. |
Severity
| CVSS 3.1 | 9.8 criticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HScored by NVD |
|---|---|
| Weakness | CWE-44, CWE-502, CWE-706 |
References
- CVE-2025-24813 on NVD
- CVE-2025-24813 in the CISA KEV catalog
- https://lists.apache.org/thread/j5fkjv2k477os90nczf2v9l61fb0kkgq (cited by CISA)
- CVE-2025-24813 on OSV
- https://lists.apache.org/thread/j5fkjv2k477os90nczf2v9l61fb0kkgq Vendor Advisory
- http://www.openwall.com/lists/oss-security/2025/03/10/5 Mailing List, Third Party Advisory
- https://lists.debian.org/debian-lts-announce/2025/04/msg00003.html Mailing List, Third Party Advisory
- https://security.netapp.com/advisory/ntap-20250321-0001/ Third Party Advisory
- https://www.vicarius.io/vsociety/posts/cve-2025-24813-detect-apache-tomcat-rce Issue Tracking
- https://www.vicarius.io/vsociety/posts/cve-2025-24813-mitigate-apache-tomcat-rce Issue Tracking
- https://www.vicarius.io/vsociety/posts/cve-2025-24813-tomcat-detect-vulnerability Issue Tracking
- https://www.vicarius.io/vsociety/posts/cve-2025-24813-tomcat-mitigation-vulnerability Issue Tracking
- https://github.com/absholi7ly/POC-CVE-2025-24813/blob/main/README.md Exploit
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-24813 Third Party Advisory, US Government Resource
Sources
Exploitation status from the CISA Known Exploited Vulnerabilities catalog. EPSS scores from FIRST. Descriptions, severity and references from the National Vulnerability Database. Open-source package versions from OSV (CC-BY 4.0). Text is shown as each source states it; Stackurity does not edit it. Check the vendor's advisory before acting.
This product uses data from the NVD API but is not endorsed or certified by the NVD.