CVEs / CVE-2025-32432
CVE-2025-32432: Craft CMS Code Injection Vulnerability
- Known exploited in the CISA KEV catalog since 20 Mar 2026
- critical 10 CVSS 3.1 (NVD)
- EPSS 99.7% chance of exploitation in the next 30 days, higher than 99% of CVEs (30 Oct 2026)
- Last changed at its sources
Are you affected? Check your servers with Stackurity: it lists the software on each server and the vulnerabilities to fix first.
Check your servers with Stackurity Already using Stackurity? Search for CVE-2025-32432
Summary
Craft CMS contains a code injection vulnerability that allows a remote attacker to execute arbitrary code.
Description
Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. Starting from version 3.0.0-RC1 to before 3.9.15, 4.0.0-RC1 to before 4.14.15, and 5.0.0-RC1 to before 5.6.17, Craft is vulnerable to remote code execution. This is a high-impact, low-complexity attack vector. This issue has been patched in versions 3.9.15, 4.14.15, and 5.6.17, and is an additional fix for CVE-2023-41892.
Affected and fixed versions
| Product | Affected | Fixed in |
|---|---|---|
| craftcms cms | >= 3.0.0-RC1, < 3.9.15 | — |
| craftcms cms | >= 4.0.0-RC1, < 4.14.15 | — |
| craftcms cms | >= 5.0.0-RC1, < 5.6.17 | — |
| Product | Affected | Fixed in |
|---|---|---|
| craftcms/cms (Packagist) | from 3.0.0-RC1, before 3.9.15 | 3.9.15 |
| craftcms/cms (Packagist) | from 4.0.0-RC1, before 4.14.15 | 4.14.15 |
| craftcms/cms (Packagist) | from 5.0.0-RC1, before 5.6.17 | 5.6.17 |
Package versions from GHSA-f3gw-9ww9-jmc3.
Exploitation
| In CISA KEV since | 20 Mar 2026 |
|---|---|
| Due date for US federal agencies | 3 Apr 2026 |
| Used in ransomware campaigns | Unknown |
| Required action | Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable. |
Severity
| CVSS 3.1 | 10 criticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:HScored by NVD |
|---|---|
| Weakness | CWE-94 |
References
- CVE-2025-32432 on NVD
- CVE-2025-32432 in the CISA KEV catalog
- https://craftcms.com/knowledge-base/craft-cms-cve-2025-32432 (cited by CISA)
- https://github.com/craftcms/cms/security/advisories/GHSA-f3gw-9ww9-jmc3 (cited by CISA)
- CVE-2025-32432 on OSV
- https://github.com/craftcms/cms/blob/3.x/CHANGELOG.md#3915---2025-04-10-critical Product, Release Notes
- https://github.com/craftcms/cms/blob/4.x/CHANGELOG.md#41415---2025-04-10-critical Product, Release Notes
- https://github.com/craftcms/cms/blob/5.x/CHANGELOG.md#5617---2025-04-10-critical Product, Release Notes
- https://github.com/craftcms/cms/commit/e1c85441fa47eeb7c688c2053f25419bc0547b47 Patch
- https://github.com/craftcms/cms/security/advisories/GHSA-f3gw-9ww9-jmc3 Vendor Advisory
- https://sensepost.com/blog/2025/investigating-an-in-the-wild-campaign-using-rce-in-craftcms/ Exploit, Press/Media Coverage
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-32432 US Government Resource
Sources
Exploitation status from the CISA Known Exploited Vulnerabilities catalog. EPSS scores from FIRST. Descriptions, severity and references from the National Vulnerability Database. Open-source package versions from OSV (CC-BY 4.0). Text is shown as each source states it; Stackurity does not edit it. Check the vendor's advisory before acting.
This product uses data from the NVD API but is not endorsed or certified by the NVD.