CVEs / CVE-2025-48384
CVE-2025-48384: Git Link Following Vulnerability
- Known exploited in the CISA KEV catalog since 25 Aug 2025
- high 8 CVSS 3.1 (from the CNA)
- EPSS 4.37% chance of exploitation in the next 30 days, higher than 91% of CVEs (30 Oct 2026)
- Last changed at its sources
Are you affected? Check your servers with Stackurity: it lists the software on each server and the vulnerabilities to fix first.
Check your servers with Stackurity Already using Stackurity? Search for CVE-2025-48384
Summary
Git contains a link following vulnerability that stems from Git’s inconsistent handling of carriage return characters in configuration files.
Description
Git is a fast, scalable, distributed revision control system with an unusually rich command set that provides both high-level operations and full access to internals. When reading a config value, Git strips any trailing carriage return and line feed (CRLF). When writing a config entry, values with a trailing CR are not quoted, causing the CR to be lost when the config is later read. When initializing a submodule, if the submodule path contains a trailing CR, the altered path is read resulting in the submodule being checked out to an incorrect location. If a symlink exists that points the altered path to the submodule hooks directory, and the submodule contains an executable post-checkout hook, the script may be unintentionally executed after checkout. This vulnerability is fixed in v2.43.7, v2.44.4, v2.45.4, v2.46.4, v2.47.3, v2.48.2, v2.49.1, and v2.50.1.
Affected and fixed versions
| Product | Affected | Fixed in |
|---|---|---|
| git git | < 2.43.7 | — |
| git git | >= 2.44.0-rc0, < 2.44.4 | — |
| git git | >= 2.45.0-rc0, < 2.45.4 | — |
| git git | >= 2.46.0-rc0, < 2.46.4 | — |
| git git | >= 2.47.0-rc0, < 2.47.3 | — |
| git git | >= 2.48.0-rc0, < 2.48.2 | — |
| git git | >= 2.49.0-rc0, < 2.49.1 | — |
| git git | >= 2.50.0-rc0, < 2.50.1 | — |
Exploitation
| In CISA KEV since | 25 Aug 2025 |
|---|---|
| Due date for US federal agencies | 15 Sep 2025 |
| Used in ransomware campaigns | Unknown |
| Required action | Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable. |
Severity
| CVSS 3.1 | 8 highCVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:HScored by the CNA ([email protected]) |
|---|---|
| Weakness | CWE-59, CWE-436 |
References
- CVE-2025-48384 on NVD
- CVE-2025-48384 in the CISA KEV catalog
- https://github.com/git/git/security/advisories/GHSA-vwqx-4fm8-6qc9 (cited by CISA)
- https://access.redhat.com/errata/RHSA-2025:13933 (cited by CISA)
- https://alas.aws.amazon.com/AL2/ALAS2-2025-2941.html (cited by CISA)
- https://linux.oracle.com/errata/ELSA-2025-11534.html (cited by CISA)
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2025-48384 (cited by CISA)
- CVE-2025-48384 on OSV
- https://github.com/git/git/security/advisories/GHSA-vwqx-4fm8-6qc9 Vendor Advisory
- http://seclists.org/fulldisclosure/2025/Sep/60 Mailing List, Third Party Advisory
- http://www.openwall.com/lists/oss-security/2025/07/08/4 Mailing List
- https://lists.debian.org/debian-lts-announce/2025/10/msg00003.html Mailing List, Third Party Advisory
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-48384 US Government Resource
Sources
Exploitation status from the CISA Known Exploited Vulnerabilities catalog. EPSS scores from FIRST. Descriptions, severity and references from the National Vulnerability Database. Open-source package versions from OSV (CC-BY 4.0). Text is shown as each source states it; Stackurity does not edit it. Check the vendor's advisory before acting.
This product uses data from the NVD API but is not endorsed or certified by the NVD.