CVEs / CVE-2025-58360
CVE-2025-58360: OSGeo GeoServer Improper Restriction of XML External Entity Reference Vulnerability
- Known exploited in the CISA KEV catalog since 11 Dec 2025
- critical 9.8 CVSS 3.1 (NVD)
- EPSS 61.1% chance of exploitation in the next 30 days, higher than 99% of CVEs (30 Oct 2026)
- Last changed at its sources
Are you affected? Check your servers with Stackurity: it lists the software on each server and the vulnerabilities to fix first.
Check your servers with Stackurity Already using Stackurity? Search for CVE-2025-58360
Summary
OSGeo GeoServer contains an improper restriction of XML external entity reference vulnerability that occurs when the application accepts XML input through a specific endpoint /geoserver/wms operation GetMap and could allow an attacker to define external entities within the XML request.
Description
GeoServer is an open source server that allows users to share and edit geospatial data. From version 2.26.0 to before 2.26.2 and before 2.25.6, an XML External Entity (XXE) vulnerability was identified. The application accepts XML input through a specific endpoint /geoserver/wms operation GetMap. However, this input is not sufficiently sanitized or restricted, allowing an attacker to define external entities within the XML request. This issue has been patched in GeoServer 2.25.6, GeoServer 2.26.3, and GeoServer 2.27.0.
Affected and fixed versions
| Product | Affected | Fixed in |
|---|---|---|
| geoserver geoserver | >= 2.26.0, < 2.26.2 | — |
| geoserver geoserver | < 2.25.6 | — |
| Product | Affected | Fixed in |
|---|---|---|
| org.geoserver.web:gs-web-app (Maven) | from 2.26.0, before 2.26.2 | 2.26.2 |
| org.geoserver:gs-wms (Maven) | from 2.26.0, before 2.26.2 | 2.26.2 |
| org.geoserver.web:gs-web-app (Maven) | before 2.25.6 | 2.25.6 |
| org.geoserver:gs-wms (Maven) | before 2.25.6 | 2.25.6 |
Package versions from GHSA-fjf5-xgmq-5525.
Exploitation
| In CISA KEV since | 11 Dec 2025 |
|---|---|
| Due date for US federal agencies | 1 Jan 2026 |
| Used in ransomware campaigns | Unknown |
| Required action | Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable. |
Severity
| CVSS 3.1 | 9.8 criticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HScored by NVD |
|---|---|
| Weakness | CWE-611 |
References
- CVE-2025-58360 on NVD
- CVE-2025-58360 in the CISA KEV catalog
- https://github.com/geoserver/geoserver/security/advisories/GHSA-fjf5-xgmq-5525 (cited by CISA)
- https://osgeo-org.atlassian.net/browse/GEOS-11922 (cited by CISA)
- CVE-2025-58360 on OSV
- https://github.com/geoserver/geoserver/security/advisories/GHSA-fjf5-xgmq-5525 Vendor Advisory
- https://osgeo-org.atlassian.net/browse/GEOS-11682 Issue Tracking
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-58360 US Government Resource
Sources
Exploitation status from the CISA Known Exploited Vulnerabilities catalog. EPSS scores from FIRST. Descriptions, severity and references from the National Vulnerability Database. Open-source package versions from OSV (CC-BY 4.0). Text is shown as each source states it; Stackurity does not edit it. Check the vendor's advisory before acting.
This product uses data from the NVD API but is not endorsed or certified by the NVD.