CVEs / CVE-2025-62593
CVE-2025-62593: Ray-Project Ray Code Injection Vulnerability
- Known exploited in the CISA KEV catalog since 17 Aug 2026
- high 8.8 CVSS 3.1 (NVD)
- EPSS 60.1% chance of exploitation in the next 30 days, higher than 99% of CVEs (30 Oct 2026)
- Last changed at its sources
Are you affected? Check your servers with Stackurity: it lists the software on each server and the vulnerabilities to fix first.
Check your servers with Stackurity Already using Stackurity? Search for CVE-2025-62593
Summary
Ray-Project Ray contains a code injection vulnerability that could allow remote code execution. Developers using Ray as a development tool may be exposed to this vulnerability exploitable through Firefox and Safari.
Description
Ray is an AI compute engine. Prior to version 2.52.0, developers working with Ray as a development tool can be exploited via a critical RCE vulnerability exploitable via Firefox and Safari. This vulnerability is due to an insufficient guard against browser-based attacks, as the current defense uses the User-Agent header starting with the string "Mozilla" as a defense mechanism. This defense is insufficient as the fetch specification allows the User-Agent header to be modified. Combined with a DNS rebinding attack against the browser, and this vulnerability is exploitable against a developer running Ray who inadvertently visits a malicious website, or is served a malicious advertisement (malvertising). This issue has been patched in version 2.52.0.
Affected and fixed versions
| Product | Affected | Fixed in |
|---|---|---|
| ray-project ray | < 2.52.0 | — |
| Product | Affected | Fixed in |
|---|---|---|
| ray (PyPI) | before 2.52.0 | 2.52.0 |
Package versions from GHSA-q279-jhrf-cc6v.
Exploitation
| In CISA KEV since | 17 Aug 2026 |
|---|---|
| Due date for US federal agencies | 20 Aug 2026 |
| Used in ransomware campaigns | Unknown |
| Required action | Apply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes). Follow applicable BOD 26-04 guidance for cloud services or discontinue use of the product if mitigations are unavailable. Stakeholders are responsible for evaluating each asset's internet exposure and ensuring adherence to BOD 26-04 patching guidelines. |
Severity
| CVSS 3.1 | 8.8 highCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HScored by NVD |
|---|---|
| Weakness | CWE-94, CWE-352 |
References
- CVE-2025-62593 on NVD
- CVE-2025-62593 in the CISA KEV catalog
- https://github.com/ray-project/ray/security/advisories/GHSA-q279-jhrf-cc6v (cited by CISA)
- https://github.com/ray-project/ray/commit/70e7c72780bdec075dba6cad1afe0832772bfe09 (cited by CISA)
- https://www.cisa.gov/news-events/directives/bod-26-04-prioritizing-security-updates-based-risk (cited by CISA)
- https://www.cisa.gov/news-events/directives/bod-26-04-implementation-guidance-prioritizing-security-updates-based-risk (cited by CISA)
- CVE-2025-62593 on OSV
- https://github.com/ray-project/ray/commit/70e7c72780bdec075dba6cad1afe0832772bfe09 Patch
- https://github.com/ray-project/ray/security/advisories/GHSA-q279-jhrf-cc6v Exploit, Patch, Vendor Advisory
- https://www.bitsight.com/blog/rondodox-botnet-infrastructure-analysis Third Party Advisory
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-62593 US Government Resource
Sources
Exploitation status from the CISA Known Exploited Vulnerabilities catalog. EPSS scores from FIRST. Descriptions, severity and references from the National Vulnerability Database. Open-source package versions from OSV (CC-BY 4.0). Text is shown as each source states it; Stackurity does not edit it. Check the vendor's advisory before acting.
This product uses data from the NVD API but is not endorsed or certified by the NVD.