Stackurity Start free trial

CVEs / CVE-2026-105134

CVE-2026-105134: Ahsay AhsayCBS Command Injection Vulnerability

Are you affected? Check your servers with Stackurity: it lists the software on each server and the vulnerabilities to fix first.

Check your servers with Stackurity Already using Stackurity? Search for CVE-2026-105134

Summary

Ahsay AhsayCBS contains a command injection vulnerability that could allow a remote attacker to execute operating system commands via manipulation of the random parameter in the Replication Receiver component’s /rps/api/json/UpdateReceivers.do endpoint. This vulnerability can be chained with CVE-2026-105133.

CISA, Known Exploited Vulnerabilities catalog

Description

A flaw has been found in Ahsay AhsayCBS up to 9.15.2.69/10.3.4.44. This vulnerability affects unknown code of the file /rps/api/json/UpdateReceivers.do of the component Replication Receiver. Executing a manipulation of the argument random can lead to os command injection. It is possible to launch the attack remotely. The exploit has been published and may be used. Upgrading to version 9.15.2.70 and 10.3.4.45 is able to resolve this issue. Upgrading the affected component is advised. The initial patch did not fix the security vulnerability properly. An update of the CVE entry to reflect this became necessary.

The CVE record, via NVD · published 4 Oct 2026 · NVD status: Analyzed

Affected and fixed versions

As stated by the CVE record (from the CNA)
ProductAffectedFixed in
Ahsay AhsayCBS9.15.2.0—
Ahsay AhsayCBS9.15.2.1—
Ahsay AhsayCBS9.15.2.2—
Ahsay AhsayCBS9.15.2.3—
Ahsay AhsayCBS9.15.2.4—
Ahsay AhsayCBS9.15.2.5—
Ahsay AhsayCBS9.15.2.6—
Ahsay AhsayCBS9.15.2.7—
Ahsay AhsayCBS9.15.2.8—
Ahsay AhsayCBS9.15.2.9—
Ahsay AhsayCBS9.15.2.10—
Ahsay AhsayCBS9.15.2.11—
Ahsay AhsayCBS9.15.2.12—
Ahsay AhsayCBS9.15.2.13—
Ahsay AhsayCBS9.15.2.14—
Ahsay AhsayCBS9.15.2.15—
Ahsay AhsayCBS9.15.2.16—
Ahsay AhsayCBS9.15.2.17—
Ahsay AhsayCBS9.15.2.18—
Ahsay AhsayCBS9.15.2.19—
Ahsay AhsayCBS9.15.2.20—
Ahsay AhsayCBS9.15.2.21—
Ahsay AhsayCBS9.15.2.22—
Ahsay AhsayCBS9.15.2.23—
Ahsay AhsayCBS9.15.2.24—
Ahsay AhsayCBS9.15.2.25—
Ahsay AhsayCBS9.15.2.26—
Ahsay AhsayCBS9.15.2.27—
Ahsay AhsayCBS9.15.2.28—
Ahsay AhsayCBS9.15.2.29—

Exploitation

In CISA KEV since14 Oct 2026
Due date for US federal agencies17 Oct 2026
Used in ransomware campaignsUnknown
Required actionApply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes). Follow applicable BOD 26-04 guidance for cloud services or discontinue use of the product if mitigations are unavailable. Stakeholders are responsible for evaluating each asset's internet exposure and ensuring adherence to BOD 26-04 patching guidelines.

Severity

CVSS 4.010 critical
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:A/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Scored by the CNA ([email protected])
WeaknessCWE-77, CWE-78

References

Sources

Exploitation status from the CISA Known Exploited Vulnerabilities catalog. EPSS scores from FIRST. Descriptions, severity and references from the National Vulnerability Database. Open-source package versions from OSV (CC-BY 4.0). Text is shown as each source states it; Stackurity does not edit it. Check the vendor's advisory before acting.

This product uses data from the NVD API but is not endorsed or certified by the NVD.