CVEs / CVE-2026-30822
CVE-2026-30822: FlowiseAI Flowise vulnerability
- high 7.7 CVSS 3.0 (from the CNA)
- EPSS 14.9% chance of exploitation in the next 30 days, higher than 96% of CVEs (2 Nov 2026)
- Last changed at its sources
Are you affected? Check your servers with Stackurity: it lists the software on each server and the vulnerabilities to fix first.
Check your servers with Stackurity Already using Stackurity? Search for CVE-2026-30822
Description
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to version 3.0.13, unauthenticated users can inject arbitrary values into internal database fields when creating leads. This issue has been patched in version 3.0.13.
Affected and fixed versions
| Product | Affected | Fixed in |
|---|---|---|
| FlowiseAI Flowise | < 3.0.13 | — |
| Product | Affected | Fixed in |
|---|---|---|
| flowise (npm) | before 3.0.13 | 3.0.13 |
Package versions from GHSA-mq4r-h2gh-qv7x.
Exploitation
Not in the CISA Known Exploited Vulnerabilities catalog as of 30 Oct 2026.
Severity
| CVSS 3.0 | 7.7 highCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:LScored by the CNA ([email protected]) |
|---|---|
| Weakness | CWE-915 |
References
- CVE-2026-30822 on NVD
- CVE-2026-30822 on OSV
- https://github.com/FlowiseAI/Flowise/releases/tag/flowise%403.0.13 Product, Release Notes
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-mq4r-h2gh-qv7x Exploit, Mitigation, Vendor Advisory
Sources
Exploitation status from the CISA Known Exploited Vulnerabilities catalog. EPSS scores from FIRST. Descriptions, severity and references from the National Vulnerability Database. Open-source package versions from OSV (CC-BY 4.0). Text is shown as each source states it; Stackurity does not edit it. Check the vendor's advisory before acting.
This product uses data from the NVD API but is not endorsed or certified by the NVD.