CVEs / CVE-2026-30824
CVE-2026-30824: FlowiseAI Flowise vulnerability
- critical 9.8 CVSS 3.1 (NVD)
- EPSS 36.9% chance of exploitation in the next 30 days, higher than 98% of CVEs (30 Oct 2026)
- Last changed at its sources
Are you affected? Check your servers with Stackurity: it lists the software on each server and the vulnerabilities to fix first.
Check your servers with Stackurity Already using Stackurity? Search for CVE-2026-30824
Description
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to version 3.0.13, the NVIDIA NIM router (/api/v1/nvidia-nim/*) is whitelisted in the global authentication middleware, allowing unauthenticated access to privileged container management and token generation endpoints. This issue has been patched in version 3.0.13.
Affected and fixed versions
| Product | Affected | Fixed in |
|---|---|---|
| FlowiseAI Flowise | < 3.0.13 | — |
| Product | Affected | Fixed in |
|---|---|---|
| flowise (npm) | before 3.0.13 | 3.0.13 |
Package versions from GHSA-5f53-522j-j454.
Exploitation
Not in the CISA Known Exploited Vulnerabilities catalog as of 30 Oct 2026.
Severity
| CVSS 3.1 | 9.8 criticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HScored by NVD |
|---|---|
| Weakness | CWE-306 |
References
- CVE-2026-30824 on NVD
- CVE-2026-30824 on OSV
- https://github.com/FlowiseAI/Flowise/releases/tag/flowise%403.0.13 Product, Release Notes
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-5f53-522j-j454 Exploit, Vendor Advisory
Sources
Exploitation status from the CISA Known Exploited Vulnerabilities catalog. EPSS scores from FIRST. Descriptions, severity and references from the National Vulnerability Database. Open-source package versions from OSV (CC-BY 4.0). Text is shown as each source states it; Stackurity does not edit it. Check the vendor's advisory before acting.
This product uses data from the NVD API but is not endorsed or certified by the NVD.