Stackurity Start free trial

CVEs / CVE-2026-34197

CVE-2026-34197: Apache ActiveMQ Improper Input Validation Vulnerability

Are you affected? Check your servers with Stackurity: it lists the software on each server and the vulnerabilities to fix first.

Check your servers with Stackurity Already using Stackurity? Search for CVE-2026-34197

Summary

Apache ActiveMQ contains an improper input validation vulnerability that allows for code injection.

CISA, Known Exploited Vulnerabilities catalog

Description

Improper Input Validation, Improper Control of Generation of Code ('Code Injection') vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ. Apache ActiveMQ Classic exposes the Jolokia JMX-HTTP bridge at /api/jolokia/ on the web console. The default Jolokia access policy permits exec operations on all ActiveMQ MBeans (org.apache.activemq:*), including BrokerService.addNetworkConnector(String) and BrokerService.addConnector(String). An authenticated attacker can invoke these operations with a crafted discovery URI that triggers the VM transport's brokerConfig parameter to load a remote Spring XML application context using ResourceXmlApplicationContext. Because Spring's ResourceXmlApplicationContext instantiates all singleton beans before the BrokerService validates the configuration, arbitrary code execution occurs on the broker's JVM through bean factory methods such as Runtime.exec(). This issue affects Apache ActiveMQ Broker: before 5.19.4, from 6.0.0 before 6.2.3; Apache ActiveMQ All: before 5.19.4, from 6.0.0 before 6.2.3; Apache ActiveMQ: before 5.19.4, from 6.0.0 before 6.2.3. Users are recommended to upgrade to version 5.19.4 or 6.2.3, which fixes the issue

The CVE record, via NVD · published 7 Apr 2026 · NVD status: Analyzed

Affected and fixed versions

As stated by the CVE record (from the CNA)
ProductAffectedFixed in
Apache Software Foundation Apache ActiveMQ Brokerbefore 5.19.45.19.4
Apache Software Foundation Apache ActiveMQ Brokerfrom 6.0.0, before 6.2.36.2.3
Apache Software Foundation Apache ActiveMQ Allbefore 5.19.45.19.4
Apache Software Foundation Apache ActiveMQ Allfrom 6.0.0, before 6.2.36.2.3
Apache Software Foundation Apache ActiveMQbefore 5.19.45.19.4
Apache Software Foundation Apache ActiveMQfrom 6.0.0, before 6.2.36.2.3
As stated by OSV
ProductAffectedFixed in
org.apache.activemq:activemq-broker (Maven)before 5.19.55.19.5
org.apache.activemq:activemq-broker (Maven)from 6.0.0, before 6.2.36.2.3
org.apache.activemq:activemq-all (Maven)before 5.19.55.19.5
org.apache.activemq:activemq-all (Maven)from 6.0.0, before 6.2.36.2.3

Package versions from GHSA-rxpj-7qvf-xv32.

Exploitation

In CISA KEV since16 Apr 2026
Due date for US federal agencies30 Apr 2026
Used in ransomware campaignsUnknown
Required actionApply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.

Severity

CVSS 3.18.8 high
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Scored by the CNA (134c704f-9b21-4f2e-91b3-4a467353bcc0)
WeaknessCWE-20, CWE-94, CWE-78

References

Sources

Exploitation status from the CISA Known Exploited Vulnerabilities catalog. EPSS scores from FIRST. Descriptions, severity and references from the National Vulnerability Database. Open-source package versions from OSV (CC-BY 4.0). Text is shown as each source states it; Stackurity does not edit it. Check the vendor's advisory before acting.

This product uses data from the NVD API but is not endorsed or certified by the NVD.