Stackurity Start free trial

CVEs / CVE-2026-34486

CVE-2026-34486: Apache Tomcat Missing Encryption of Sensitive Data Vulnerability

Are you affected? Check your servers with Stackurity: it lists the software on each server and the vulnerabilities to fix first.

Check your servers with Stackurity Already using Stackurity? Search for CVE-2026-34486

Summary

Apache Tomcat contains a missing encryption of sensitive data vulnerability that allows the bypass of the EncryptInterceptor. This vulnerability can be chained with CVE‑2025‑24813.

CISA, Known Exploited Vulnerabilities catalog

Description

Missing Encryption of Sensitive Data vulnerability in Apache Tomcat due to the fix for CVE-2026-29146 allowing the bypass of the EncryptInterceptor. This issue affects Apache Tomcat: 11.0.20, 10.1.53, 9.0.116. Users are recommended to upgrade to version 11.0.21, 10.1.54 or 9.0.117, which fix the issue.

The CVE record, via NVD · published 9 Apr 2026 · NVD status: Analyzed

Affected and fixed versions

As stated by the CVE record (from the CNA)
ProductAffectedFixed in
Apache Software Foundation Apache Tomcat11.0.20—
Apache Software Foundation Apache Tomcat10.1.53—
Apache Software Foundation Apache Tomcat9.0.116—
As stated by OSV
ProductAffectedFixed in
org.apache.tomcat:tomcat-tribes (Maven)from 11.0.20, before 11.0.2111.0.21
org.apache.tomcat:tomcat-tribes (Maven)from 10.1.53, before 10.1.5410.1.54
org.apache.tomcat:tomcat-tribes (Maven)from 9.0.116, before 9.0.1179.0.117
org.apache.tomcat:tomcat (Maven)from 11.0.20, before 11.0.2111.0.21
org.apache.tomcat:tomcat (Maven)from 10.1.53, before 10.1.5410.1.54
org.apache.tomcat:tomcat (Maven)from 9.0.116, before 9.0.1179.0.117

Package versions from GHSA-69r9-qgr7-g2wj.

Exploitation

In CISA KEV since4 Aug 2026
Due date for US federal agencies7 Aug 2026
Used in ransomware campaignsUnknown
Required actionApply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes). Follow applicable BOD 26-04 guidance for cloud services or discontinue use of the product if mitigations are unavailable. Stakeholders are responsible for evaluating each asset's internet exposure and ensuring adherence to BOD 26-04 patching guidelines.

Severity

CVSS 3.17.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Scored by the CNA (134c704f-9b21-4f2e-91b3-4a467353bcc0)
WeaknessCWE-311, CWE-807

References

Sources

Exploitation status from the CISA Known Exploited Vulnerabilities catalog. EPSS scores from FIRST. Descriptions, severity and references from the National Vulnerability Database. Open-source package versions from OSV (CC-BY 4.0). Text is shown as each source states it; Stackurity does not edit it. Check the vendor's advisory before acting.

This product uses data from the NVD API but is not endorsed or certified by the NVD.