Stackurity Start free trial

CVEs / CVE-2026-35029

CVE-2026-35029: BerriAI litellm vulnerability

Are you affected? Check your servers with Stackurity: it lists the software on each server and the vulnerabilities to fix first.

Check your servers with Stackurity Already using Stackurity? Search for CVE-2026-35029

Description

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to 1.83.0, the /config/update endpoint does not enforce admin role authorization. A user who is already authenticated into the platform can then use this endpoint to modify proxy configuration and environment variables, register custom pass-through endpoint handlers pointing to attacker-controlled Python code, achieving remote code execution, read arbitrary server files by setting UI_LOGO_PATH and fetching via /get_image, and take over other privileged accounts by overwriting UI_USERNAME and UI_PASSWORD environment variables. Fixed in v1.83.0.

The CVE record, via NVD · published 6 Apr 2026 · NVD status: Modified

Affected and fixed versions

As stated by the CVE record (from the CNA)
ProductAffectedFixed in
BerriAI litellm< 1.83.0—
As stated by OSV
ProductAffectedFixed in
litellm (PyPI)before 1.83.01.83.0

Package versions from GHSA-53mr-6c8q-9789.

Exploitation

Not in the CISA Known Exploited Vulnerabilities catalog as of 30 Oct 2026.

Severity

CVSS 3.18.8 high
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Scored by NVD
WeaknessCWE-863, CWE-425

References

Sources

Exploitation status from the CISA Known Exploited Vulnerabilities catalog. EPSS scores from FIRST. Descriptions, severity and references from the National Vulnerability Database. Open-source package versions from OSV (CC-BY 4.0). Text is shown as each source states it; Stackurity does not edit it. Check the vendor's advisory before acting.

This product uses data from the NVD API but is not endorsed or certified by the NVD.