CVEs / CVE-2026-42208
CVE-2026-42208: BerriAI LiteLLM SQL Injection Vulnerability
- Known exploited in the CISA KEV catalog since 8 May 2026
- critical 9.8 CVSS 3.1 (NVD)
- EPSS 89.4% chance of exploitation in the next 30 days, higher than 99% of CVEs (30 Oct 2026)
- Last changed at its sources
Are you affected? Check your servers with Stackurity: it lists the software on each server and the vulnerabilities to fix first.
Check your servers with Stackurity Already using Stackurity? Search for CVE-2026-42208
Summary
BerriAI LiteLLM contains a SQL injection vulnerability that allows an attacker to read data from the proxy's database and potentially modify it, leading to unauthorized access to the proxy and the credentials it manages.
Description
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.81.16 to before version 1.83.7, a database query used during proxy API key checks mixed the caller-supplied key value into the query text instead of passing it as a separate parameter. An unauthenticated attacker could send a specially crafted Authorization header to any LLM API route (for example POST /chat/completions) and reach this query through the proxy's error-handling path. An attacker could read data from the proxy's database and may be able to modify it, leading to unauthorised access to the proxy and the credentials it manages. This issue has been patched in version 1.83.7.
Affected and fixed versions
| Product | Affected | Fixed in |
|---|---|---|
| BerriAI litellm | >= 1.81.16, < 1.83.7 | — |
| Product | Affected | Fixed in |
|---|---|---|
| litellm (PyPI) | from 1.81.16, before 1.83.7 | 1.83.7 |
Package versions from GHSA-r75f-5x8p-qvmc.
Exploitation
| In CISA KEV since | 8 May 2026 |
|---|---|
| Due date for US federal agencies | 11 May 2026 |
| Used in ransomware campaigns | Unknown |
| Required action | Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable. |
Severity
| CVSS 3.1 | 9.8 criticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HScored by NVD |
|---|---|
| Weakness | CWE-89 |
References
- CVE-2026-42208 on NVD
- CVE-2026-42208 in the CISA KEV catalog
- https://github.com/BerriAI/litellm/security/advisories/GHSA-r75f-5x8p-qvmc (cited by CISA)
- CVE-2026-42208 on OSV
- https://github.com/BerriAI/litellm/releases/tag/v1.83.7-stable Product, Release Notes
- https://github.com/BerriAI/litellm/security/advisories/GHSA-r75f-5x8p-qvmc Mitigation, Patch, Vendor Advisory
- https://access.redhat.com/security/cve/CVE-2026-42208 Third Party Advisory
- https://bugzilla.redhat.com/show_bug.cgi?id=2463965 Mitigation, Third Party Advisory
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-42208.json Third Party Advisory
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-42208 US Government Resource
Sources
Exploitation status from the CISA Known Exploited Vulnerabilities catalog. EPSS scores from FIRST. Descriptions, severity and references from the National Vulnerability Database. Open-source package versions from OSV (CC-BY 4.0). Text is shown as each source states it; Stackurity does not edit it. Check the vendor's advisory before acting.
This product uses data from the NVD API but is not endorsed or certified by the NVD.