CVEs / CVE-2026-42271
CVE-2026-42271: BerriAI LiteLLM Command Injection Vulnerability
- Known exploited in the CISA KEV catalog since 8 Jun 2026
- high 8.8 CVSS 3.1 (NVD)
- EPSS 91.4% chance of exploitation in the next 30 days, higher than 99% of CVEs (30 Oct 2026)
- Last changed at its sources
Are you affected? Check your servers with Stackurity: it lists the software on each server and the vulnerabilities to fix first.
Check your servers with Stackurity Already using Stackurity? Search for CVE-2026-42271
Summary
BerriAI LiteLLM contains a command injection vulnerability that could allow any authenticated user, including holders of low-privilege internal-user keys, to run arbitrary commands on the host.
Description
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.74.2 to before version 1.83.7, two endpoints used to preview an MCP server before saving it — POST /mcp-rest/test/connection and POST /mcp-rest/test/tools/list — accepted a full server configuration in the request body, including the command, args, and env fields used by the stdio transport. When called with a stdio configuration, the endpoints attempted to connect, which spawned the supplied command as a subprocess on the proxy host with the privileges of the proxy process. The endpoints were gated only by a valid proxy API key, with no role check. Any authenticated user — including holders of low-privilege internal-user keys — could therefore run arbitrary commands on the host. This issue has been patched in version 1.83.7.
Affected and fixed versions
| Product | Affected | Fixed in |
|---|---|---|
| BerriAI litellm | >= 1.74.2, < 1.83.7 | — |
| Product | Affected | Fixed in |
|---|---|---|
| litellm (PyPI) | from 1.74.2, before 1.83.7 | 1.83.7 |
Package versions from GHSA-v4p8-mg3p-g94g.
Exploitation
| In CISA KEV since | 8 Jun 2026 |
|---|---|
| Due date for US federal agencies | 22 Jun 2026 |
| Used in ransomware campaigns | Unknown |
| Required action | Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable. |
Severity
| CVSS 3.1 | 8.8 highCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HScored by NVD |
|---|---|
| Weakness | CWE-77, CWE-78 |
References
- CVE-2026-42271 on NVD
- CVE-2026-42271 in the CISA KEV catalog
- https://github.com/BerriAI/litellm/security/advisories/GHSA-v4p8-mg3p-g94g (cited by CISA)
- https://github.com/BerriAI/litellm/releases/tag/v1.83.7-stable (cited by CISA)
- CVE-2026-42271 on OSV
- https://github.com/BerriAI/litellm/releases/tag/v1.83.7-stable Product, Release Notes
- https://github.com/BerriAI/litellm/security/advisories/GHSA-v4p8-mg3p-g94g Mitigation, Patch, Vendor Advisory
- https://access.redhat.com/errata/RHSA-2026:27784 Third Party Advisory
- https://access.redhat.com/errata/RHSA-2026:28960 Third Party Advisory
- https://access.redhat.com/errata/RHSA-2026:30056 Third Party Advisory
- https://access.redhat.com/security/cve/CVE-2026-42271 Third Party Advisory
- https://bugzilla.redhat.com/show_bug.cgi?id=2467924 Third Party Advisory
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-42271.json Third Party Advisory
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-42271 US Government Resource
Sources
Exploitation status from the CISA Known Exploited Vulnerabilities catalog. EPSS scores from FIRST. Descriptions, severity and references from the National Vulnerability Database. Open-source package versions from OSV (CC-BY 4.0). Text is shown as each source states it; Stackurity does not edit it. Check the vendor's advisory before acting.
This product uses data from the NVD API but is not endorsed or certified by the NVD.