Stackurity Start free trial

CVEs / CVE-2026-44578

CVE-2026-44578: vercel next.js vulnerability

Are you affected? Check your servers with Stackurity: it lists the software on each server and the vulnerabilities to fix first.

Check your servers with Stackurity Already using Stackurity? Search for CVE-2026-44578

Description

Next.js is a React framework for building full-stack web applications. From 13.4.13 to before 15.5.16 and 16.2.5, self-hosted applications using the built-in Node.js server can be vulnerable to server-side request forgery through crafted WebSocket upgrade requests. An attacker can cause the server to proxy requests to arbitrary internal or external destinations, which may expose internal services or cloud metadata endpoints. Vercel-hosted deployments are not affected. This vulnerability is fixed in 15.5.16 and 16.2.5.

The CVE record, via NVD · published 13 May 2026 · NVD status: Modified

Affected and fixed versions

As stated by the CVE record (from the CNA)
ProductAffectedFixed in
vercel next.js>= 16.0.0, < 16.2.5—
vercel next.js>= 13.4.13, < 15.5.16—
As stated by OSV
ProductAffectedFixed in
next (npm)from 13.4.13, before 15.5.1615.5.16
next (npm)from 16.0.0, before 16.2.516.2.5

Package versions from GHSA-c4j6-fc7j-m34r.

Exploitation

Not in the CISA Known Exploited Vulnerabilities catalog as of 30 Oct 2026.

Severity

CVSS 3.18.6 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
Scored by the CNA ([email protected])
WeaknessCWE-918

References

Sources

Exploitation status from the CISA Known Exploited Vulnerabilities catalog. EPSS scores from FIRST. Descriptions, severity and references from the National Vulnerability Database. Open-source package versions from OSV (CC-BY 4.0). Text is shown as each source states it; Stackurity does not edit it. Check the vendor's advisory before acting.

This product uses data from the NVD API but is not endorsed or certified by the NVD.