CVEs / CVE-2026-45434
CVE-2026-45434: Apache Software Foundation Apache OFBiz vulnerability
- critical 9.8 CVSS 3.1 (from the CNA)
- EPSS 21.2% chance of exploitation in the next 30 days, higher than 97% of CVEs (30 Oct 2026)
- Last changed at its sources
Are you affected? Check your servers with Stackurity: it lists the software on each server and the vulnerabilities to fix first.
Check your servers with Stackurity Already using Stackurity? Search for CVE-2026-45434
Description
Improper Authentication vulnerability in Apache OFBiz via Password-Change Logic Flaw Leading to Remote Code Execution This issue affects Apache OFBiz: before 24.09.06. Users are recommended to upgrade to version 24.09.06, which fixes the issue.
Affected and fixed versions
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software Foundation Apache OFBiz | before 24.09.06 | 24.09.06 |
Exploitation
Not in the CISA Known Exploited Vulnerabilities catalog as of 30 Oct 2026.
Severity
| CVSS 3.1 | 9.8 criticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HScored by the CNA (134c704f-9b21-4f2e-91b3-4a467353bcc0) |
|---|---|
| Weakness | CWE-287 |
References
- CVE-2026-45434 on NVD
- CVE-2026-45434 on OSV
- https://lists.apache.org/thread/yw4owrzl0yho1yx7oqxvr6xjkmln9tq8 Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2026/05/19/29
Sources
Exploitation status from the CISA Known Exploited Vulnerabilities catalog. EPSS scores from FIRST. Descriptions, severity and references from the National Vulnerability Database. Open-source package versions from OSV (CC-BY 4.0). Text is shown as each source states it; Stackurity does not edit it. Check the vendor's advisory before acting.
This product uses data from the NVD API but is not endorsed or certified by the NVD.