CVEs / CVE-2026-66066
CVE-2026-66066: rails rails vulnerability
- critical 9.5 CVSS 4.0 (from the CNA)
- EPSS 30% chance of exploitation in the next 30 days, higher than 98% of CVEs (1 Nov 2026)
- Last changed at its sources
Are you affected? Check your servers with Stackurity: it lists the software on each server and the vulnerabilities to fix first.
Check your servers with Stackurity Already using Stackurity? Search for CVE-2026-66066
Description
Action Pack is a framework for handling and responding to web requests. In versions prior to 7.2.3.2, 8.0.5.1 and 8.1.3.1, Active Storage does not disable libvips operations marked unsafe for untrusted content, allowing a crafted upload to invoke such an operation. Consuming applications are affected when configured to use libvips and accept image uploads from untrusted users. An unauthenticated attacker may exploit this behavior to read arbitrary files accessible to the Rails process, including environment variables and application secrets. Exposure of credentials such as secret_key_base or external-service tokens may enable remote code execution or lateral movement. This issue has been fixed in versions 7.2.3.2, 8.0.5.1 and 8.1.3.1.
Affected and fixed versions
| Product | Affected | Fixed in |
|---|---|---|
| rails rails | < 7.2.3.2 | — |
| rails rails | >= 8.0.0.beta1, < 8.0.5.1 | — |
| rails rails | >= 8.1.0.beta1, < 8.1.3.1 | — |
| Product | Affected | Fixed in |
|---|---|---|
| activestorage (RubyGems) | before 7.2.3.2 | 7.2.3.2 |
| activestorage (RubyGems) | from 8.0.0.beta1, before 8.0.5.1 | 8.0.5.1 |
| activestorage (RubyGems) | from 8.1.0.beta1, before 8.1.3.1 | 8.1.3.1 |
Package versions from GHSA-xr9x-r78c-5hrm.
Exploitation
Not in the CISA Known Exploited Vulnerabilities catalog as of 30 Oct 2026.
Severity
| CVSS 4.0 | 9.5 criticalCVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:XScored by the CNA ([email protected]) |
|---|---|
| Weakness | CWE-1188 |
References
- CVE-2026-66066 on NVD
- CVE-2026-66066 on OSV
- https://github.com/rails/rails/commit/1c01bb587206ee6eb0e1179c2cef96a6a47acb1e
- https://github.com/rails/rails/commit/349e7a5d5b4b715af1e416db824f3c078a7d59e5
- https://github.com/rails/rails/commit/d79b7f4aa17dec8ce4960fef05733c8c0c7ef49a
- https://github.com/rails/rails/releases/tag/v7.2.3.2
- https://github.com/rails/rails/releases/tag/v8.0.5.1
- https://github.com/rails/rails/releases/tag/v8.1.3.1
- https://github.com/rails/rails/security/advisories/GHSA-xr9x-r78c-5hrm
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/activestorage/CVE-2026-66066.yml
- https://thehackernews.com/2026/07/critical-rails-flaw-could-let.html
- http://www.openwall.com/lists/oss-security/2026/07/29/9
- http://www.openwall.com/lists/oss-security/2026/08/01/6
- https://ethiack.com/info-hub/research/kindarails2shell-rails-rce-cve-2026-66066
- https://github.com/rails/rails-forensics-CVE-2026-66066
Sources
Exploitation status from the CISA Known Exploited Vulnerabilities catalog. EPSS scores from FIRST. Descriptions, severity and references from the National Vulnerability Database. Open-source package versions from OSV (CC-BY 4.0). Text is shown as each source states it; Stackurity does not edit it. Check the vendor's advisory before acting.
This product uses data from the NVD API but is not endorsed or certified by the NVD.