Stackurity Start free trial

CVEs / CVE-2020-26217

CVE-2020-26217: x-stream xstream vulnerability

Are you affected? Check your servers with Stackurity: it lists the software on each server and the vulnerabilities to fix first.

Check your servers with Stackurity Already using Stackurity? Search for CVE-2020-26217

Description

XStream before version 1.4.14 is vulnerable to Remote Code Execution.The vulnerability may allow a remote attacker to run arbitrary shell commands only by manipulating the processed input stream. Only users who rely on blocklists are affected. Anyone using XStream's Security Framework allowlist is not affected. The linked advisory provides code workarounds for users who cannot upgrade. The issue is fixed in version 1.4.14.

The CVE record, via NVD · published 16 Nov 2020 · NVD status: Analyzed

Affected and fixed versions

As stated by the CVE record (from the CNA)
ProductAffectedFixed in
x-stream xstream< 1.4.14—
As stated by OSV
ProductAffectedFixed in
com.thoughtworks.xstream:xstream (Maven)before 1.4.14-java71.4.14-java7

Package versions from GHSA-mw36-7c6c-q4q2.

Exploitation

Not in the CISA Known Exploited Vulnerabilities catalog as of 4 Nov 2026.

Severity

CVSS 3.18.8 high
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Scored by NVD
WeaknessCWE-78

References

Sources

Exploitation status from the CISA Known Exploited Vulnerabilities catalog. EPSS scores from FIRST. Descriptions, severity and references from the National Vulnerability Database. Open-source package versions from OSV (CC-BY 4.0). Text is shown as each source states it; Stackurity does not edit it. Check the vendor's advisory before acting.

This product uses data from the NVD API but is not endorsed or certified by the NVD.